Using MathType with Microsoft Visio

Microsoft Visio is a diagramming application that allows you to produce many types of flowcharts and other business diagrams and drawings. MathType works with Visio, allowing you to create equations to annotate or label your flowcharts and diagrams.

Caution

Caution: If you paste Visio 2013 diagrams into Word, the entire diagram, including equations, will be fuzzy. We offer tips to minimize this.

Add an equation to Visio

There are a couple of ways to insert MathType equations into Visio:

  • Copy & paste or drag & drop. Create the equation in MathType then either copy it and paste it into Visio, or select it and drag it over to your diagram.

  • Use the Insert > Object button. On Visio's Insert tab in the Ribbon is a Text group. Within the Text group, there is an Object button. Clicking this button will bring up the Insert Object dialogue. Choose MathType 7.0 Equation from the list and click OK in this dialogue. After creating the equation, close MathType and the equation will remain in your diagram. You can now move it into position.

Warning

Warning! MathType equations are "vector objects", so they should scale smoothly if you click and drag to resize one. However, they also contain fonts, and it's hard sometimes for an application to retain all the information it needs to render a resized object containing fonts accurately. We recommend correctly sizing the equations in MathType by using the Define dialogue in MathType's Size menu. Clicking to drag an equation to resize it may not always cause problems, but when it does cause problems, it always seems to happen at the 11th hour when you're getting ready to submit a project or an assignment. Follow our recommendation and let MathType do the sizing for you, or yours may look something like this:

resizing_equation.gif

If you copy the diagram and paste it into Word…

Microsoft Word has some excellent drawing tools, and you can make decent drawings and diagrams directly in Word. It's not Visio, though, and doesn't have the capability of Visio, so if you work in both apps, you'll at some point notice a decrease in quality if you paste your Visio 2013 diagram into Word. This is not a problem with earlier or later versions of Visio. Still, with Visio 2013 only, both the diagram and the equation will lose quality when you paste into Word, but this is more noticeable in the equation. To minimize this, it's best to create the drawing in Visio and add the equations in Word. Compare these two diagrams:

diagram_equation_visio_to_word.png
diagram_equation_visio2013_equation_word2013.png

The one on the left was created in Visio 2013, and the MathType equation was inserted into Visio. The two items were then copied and pasted into Word. (They were not grouped first, but it won't matter; the quality will be the same.) In the diagram on the right, the triangle was created in Visio, and the MathType equation was added into Word. This issue was fixed in Visio 2016 and is no longer an issue.

One additional step you'll have to follow if you do this is to change the equation properties to "floating" (either "in front of text" or "behind text"). First, insert the equation, right-click it and choose "Format Object". Click the "Layout" tab, select "In Front of text", and click OK. Now you can click on the equation and drag it into position. This isn't necessary except in Visio 2013. In other versions of Visio, you'll achieve good results by copying the diagram and equations from Visio and pasting them into Word.

Note one more issue with Visio 2013 : when creating PDFs from Visio 2013, the equations are blurry. Like the issue above, this is an issue with Visio, not with MathType There's nothing you can do to change this except upgrading Visio to Visio 2016 or later.

Edit an equation in Visio

If you double-click a MathType equation, it will open in MathType for you to edit. Make the necessary changes and close the MathType window. When you close MathType, a pop-up dialogue may ask if you want to save the changes to the equation in your document. If you want the changes to be held without being asked the question each time, check the box that says, "Don't show me this again".