Best practices for using MathType

There are very few "absolutes" for using MathType. That is, not very many times when we can say "absolutely do this" or "absolutely don't do that". Most of those are pretty obvious, like "Don't use MathType when sitting with your laptop on a floatie in the middle of a swimming pool." No one needs to tell you not to do that; it's pretty obvious.

The things you'll see on this page are not procedure; they're technique. However, we can say these techniques have been developed either as a result of using MathType literally for decades or as a result of seeing many customers writing in with issues caused by having used a technique other than what you'll see here.

So it's up to you — if something's working for you, it's probably an OK technique. The techniques here are intended to provide help when something doesn't go right, or better yet, to prevent things from going wrong in the first place.

  1. Copy & paste — Using copy & paste to insert equations: This should normally work out, but there are precautions to be aware of.
  2. Equation numbers — Managing numbered equations and their corresponding equation numbers: MathType can seem like magic when it comes to numbered equations and equation references, but you can control this magic and make the output just how you like it (or how your style guide specifies).
  3. Fonts — Specific fonts to avoid with MathType: There aren't many, but it's important to know which ones to avoid.
  4. Size — Setting the size of an equation: Don't click and drag a corner. Read below to find out why.
  5. Spacing — Setting paragraph spacing in a document: If you've ever had the top and bottom of your equations clipped or if you don't like the uneven paragraph spacing after you insert equations, this section has some tips.
  6. Toolbar — Use the toolbar to save common expressions. The title says a lot, but read below for more.

All "power" MathType users, and all users of MathType for any time at all, know there are often several ways to get anything done in MathType. For example, if you want to insert a Greek letter mu into an equation, you could click to expand the lower case Greek letters palette, then click the icon for mu. You could also press the keyboard shortcut Ctrl+G (+G Mac), followed by the M key. There's nothing inherently right or wrong about either method.

What about changing the appearance of an equation created with MathType's default configuration? For fonts, that's Times New Roman, 12pt. Many of our customers are faculty members who use MathType in a word processor and a presentation application during the same lesson preparation period. So here's a common scenario…

You're working in Microsoft Word to create a lesson handout to print and give to your students in class. You're also working on your lesson slides, using Microsoft PowerPoint. You've inserted an equation into the Word document. You want to use this equation also on one of your slides.

In this scenario, there are at least two decisions to make:

  1. How will you get the equation from Word into PowerPoint?
  2. You're not using 12pt text in PowerPoint, so how will you make it larger to match the size of the text on your slide?

Let's defer decision #1 to the section of this page dealing with copy & paste. For the rest of this part, we'll deal with decision #2.

You've no doubt noticed when you add the equation to your slide, there are 8 "resizing handles", visible as white circles:

12-point equation in PowerPoint, with 8 resizing handles shown.

It's very tempting to just click the circle in one of the corners and drag until the equation "looks about right". We caution against that for 3 very practical reasons and 1 just-as-practical, but less common, reason.

  • Click & drag to resize takes too long. Doing it for one equation isn't all that bad, but multiply those few seconds by 100 equations in a PowerPoint file and it adds up. Besides, it's tedious and boring.
  • If you resize equations by click & drag, not only will no 2 equations be exactly the same size, but none of them will exactly match the size of the text on your slide.
  • You're not using MathType to result in equations that "look about right". You're using MathType to write equations that look great!
  • We've seen the "click & drag" method result in some very bizarre issues that are difficult to diagnose unless you know where to look -- like this one (actual example from a customer; equation changed to protect the innocent):
    Clicking and dragging to resize this equation resulted in it being flipped backward.

We recommend when resizing equations, don't use the resizing handles. Rather, use MathType's Size menu. Look for the Define command at the bottom of the menu. If you click Define, you'll see something like this:

MathType's Define Sizes dialog

We'll not go into details of using the Define Sizes dialog here, because those details are fully described elsewhere in the docs. What we would like to suggest here is to set Full size to be equal to the size of the font nearest the equation on the slide. In the case of our example equation, that's 20pt. (If you want it a little larger for emphasis, or maybe a little smaller than the text so the large equation will fit onto the slide, the point [pun sort of intended] is to set Define Sizes to be exactly the size you need, not one you've guessed at by dragging a corner.)

Wouldn't that take longer though — going through this process every time you use an equation from Word?

Yes it would. That's why we have another suggestion: use preference files. In MathType, a preference file gives you a way to easily apply different, pre-defined settings to an equation. The settings contained in a preference file are

We recommend saving one preference file with the spacing, styles (fonts), and sizes you're using in Word, and a second preference file appropriate for PowerPoint. The most recent 4 preference files you've used will always be at the bottom of MathType's Preferences menu, so after you place the equation from Word into PowerPoint, apply the appropriate preference file to the equation. When you go back to Word, switch to the preference file you're using in Word.

Here's how our slide looks with a 20pt equation:

20-point equation in PowerPoint, matching the size of nearby text.

In some applications, that's your only choice — copy & paste. However, the applications our customers most commonly use with MathType are Microsoft Office (Word and PowerPoint) and the Apple applications formerly known as iWork (Pages, Keynote, Numbers). All of these applications have an integrated means of inserting MathType equations other than copy & paste. (Note in many cases you can also select an equation in MathType, point to it with the mouse, click, then drag the equation over to wherever you want it to be. That's called drag & drop, and whenever we refer to copy & paste on this page, we mean both copy & paste and drag & drop unless otherwise noted.)

It's so easy to copy & paste though; why would I want to do it any other way?

There are sometimes issues caused by copy & paste that aren't caused by using the Insert Equation command (or button on the MathType tab), but those don't always happen. What does always happen though, is it takes you more time to copy & paste than it takes to use the command or button to insert an equation. People tend to think copy & paste is faster; it's not.

Here are the steps (we'll use Command in the table to mean either the Insert Equation command in Pages or its siblings or clicking one of the Insert Equation buttons in Word or PowerPoint):

Copy & paste (assuming you open MathType and keep it open)Command
  1. Create the equation.
  2. Select the equation.
  3. Copy the equation.
  4. Switch to Word (or other app).
  5. (If the insertion point/cursor isn't where you want the equation) click in the document where you want the equation to go.
  6. Paste the equation.
  1. Click the Insert Equation button.
  2. Create the equation.
  3. Close MathType.
                                                                                                    

So it takes 2 more steps to copy & paste than it does to click the button and close MathType every time if you keep the MathType window open after the first copy & paste (or 3 if you have to click inside the document).

Any other reasons not to copy & paste or drag & drop?

  1. "Transposed" equations. That is, you paste one equation into MathType, but when you double-click to edit the equation, a completely different one opens in MathType. We have documented this issue in a separate article, so we won't detail it here.
  2. Sometimes after copy & paste, the equation isn't properly aligned with the text in the document — like this:
    The equation is positioned too high, and not aligned vertically with the text.
  3. In some versions of PowerPoint, copy & paste doesn't cause any specific issues, but drag & drop does. Specifically, if you drag & drop an equation from MathType into PowerPoint, the equation is no longer a MathType equation; it's an OMML equation (i.e., Word equation).
    ""

For the most part, if a font appears in the list of fonts available in MathType, it's OK to use:

In the Define Styles dialog, you can see what fonts are available to MathType.

Still, there are 2 types of fonts you should completely avoid in MathType, and one other category you should avoid unless you completely know what those fonts are for.

  1. "Math" fonts: The font has Math in its name; what could possibly go wrong? Turns out, plenty. This doesn't happen with all fonts named <something> Math, but it does in one very prominent one (Cambria Math) and one lesser-known font that we know about (Latin Modern Math); no doubt there are more. We have a separate article that goes into more detail about this issue, so we won't go into the details here.
  2. Fonts with the @ symbol at the beginning of the name: You may or may not have these on your computer, but if you do, absolutely do not use them with MathType. Nothing catastrophic will happen if you use them. In fact, feel free to try it just to see what the equations look like, but it won't be the output you're looking for. These fonts, such as @Arial Unicode MS (not equivalent to "Arial Unicode MS"), @MS Mincho (not equivalent to "MS Mincho"), and other fonts whose names begin with the @ symbol are to enable Eastern Asian languages to be formatted for reading top-to-bottom, rather than left-to-right or right-to-left, and should not be used with MathType.
  3. "Tiger" fonts: The Tiger fonts Symbol Tiger, Symbol Tiger Expert, and MT Extra Tiger were designed to be used for creating accessible documents for the blind, and intended to be used with Tiger Software Suite. Their use elsewhere will have unpredictable results.

What's the big deal? You type, you print, you're finished. Word's pretty easy to use, but the way it manages leading (the distance from one line of text to another) is a source of irritation to some because it doesn't look quite up to textbook quality.

Here's a simple example. Notice the uneven leading in this paragraph:

"Tall" equations naturally require more space between lines than equations that aren't so tall.

This is mostly, but not totally, Word's fault. MathType contributes to it by the overall bounding box of its equation/expression "objects". ("Objects" is the term for MathType equations, Excel charts, and other editable items inserted into a Word document.) You can see the bounding box of an equation by clicking it once to select it:

There's only a very small distance between the bottom of an equation bounding box in one line and the top of an equation bounding box in the following line.

Note it's not possible to select multiple equations in a document. This is a composite screen shot to show the relationship between multiple equation bounding boxes in a single paragraph.

Standard single-spaced lines contain 20% of padding, so a paragraph with 12pt text, for example, would have 14.4pt spacing between the baseline of one line and the baseline of the next line. The default for the Normal style in Word's Normal template is not Single spacing in a paragraph, but "Multiple: 1.08". So to find the normal spacing (in Word) for that 12pt paragraph, multiply by 1.2, then again by 1.08. That gives 15.552, so in the Paragaph dialog it would be "Exactly 15.6pt".

That's where MathType complicates matters. Rather than repeat information contained elsewhere in our documentation, we have another article that goes into more detail about "Exact" paragraph line spacing, and how to determine what the proper spacing should be.

Here we've adjusted the spacing to be exactly the size of our font·(1.2)·(1.08):

The paragraph has consistent leading from one line to the next, but the equations are clipped top and bottom.

We need to account for the height of the equations though, so now we've adjusted our example paragraph considering everything, and the leading is more even:

The paragraph now has consistent leading from one line to the next.

There are a few key points concerning MathType equation numbers. If you understand these points, it's much easier to use numbered equations and references effectively.

  1. Field codes: Microsoft describes field codes as "useful as placeholders for data that might change in your document, and you can use them to automate certain aspects of your document. Field codes are inserted for you when you use Word features like page numbers or a table of contents, but you can insert field codes manually for other tasks like performing calculations or filling in document content from a data source." MathType uses field codes not only to identify equations in a Word document, but to add equation numbers and references. You don't have to completely understand field codes in order to be an effective MathType user. Just understand that you can't change an equation number by clicking it and typing in a new number or a new format for the existing number.
  2. The Format Equation Numbers dialog is where you define your equation number format. For example, (1.3), or [3.A.12], or Equation 2.5. The Format Equation Numbers dialog is covered elsewhere, so we won't go into detail here.
  3. The Word style named MTDisplayEquation is where you define the position of a numbered equation in its line and the location of the equation number.
  4. MathType itself has some alignment commands that are useful when it comes to numbered equations.

Here are a few scenarios where using the information mentioned above can direct MathType to treat display equations and their numbers and references so as to not create any surprises for you:

MathType's Insert Right-numbered button in Word inserts an equation centered on the line, with the equation number right-aligned with the right margin. Your style guide specifies display equations positioned 1 inch from the left margin.
Your document was initially a 2-column document and you decide to switch to single-column layout. Now your display equations and equation numbers aren't positioned correctly.
One of your numbered "equations" is actually 3 equations, each on its own line, that you created in MathType as one equation object. The equation number is vertically centered on this equation group, but you want the number aligned with the 3rd equation (the bottom one) in the group.

Rather than address these scenarios step-by-step, let's look at items number 3 and 4 from the list above, and you can apply that general knowledge to your own numbered equation scenario.

Word's MTDisplayEquation style

We have details on the MTDisplayEquation style in another article, but it's important enough to repeat this statement from the article: the MTDisplayEquation style is not included by default on Word's Style Gallery, nor does it exist before you insert a display equation into the current document. The article explains how to open the style and adjust its definition to suit your needs. The first 2 scenarios described above can be resolved by properly changing this style to conform to your needs.

MathType's alignment commands

In MathType's Format menu, there are 8 alignment commands that are normally grayed-out. Chances are, three of these you've probably never used.

The Align commands are normally not enabled for use in MathType's Format menu.

With only one line in the MathType equation editing workspace, these 8 commands will be grayed-out. They'll be enabled once you create a pile (i.e., multiple lines inside MathType) or add a matrix to the equation.

The top group commands (left, center, right, etc.) are useful, but not here. We're concerned with the next group of 3 — Align at Top, Align at Center (actually it should say "Middle" rather than "Center", but it says what it says), and Align at Bottom. In the scenario mentioned above, you'd want to apply Align at Bottom to the pile of 3 equations. These 3 commands control the position of the equation object in relation to the surrounding text, so if we apply Align at Bottom, it will cause the equation number to be aligned with the bottom equation in the group of 3 equations within our equation object.

The bottom 3 rows of MathType's toolbar comprise the customizable toolbar, identified by the red bar below:

MathType's customizable toolbar is beneath the row of template palettes.

What you see on the customizable toolbar when you install MathType are only examples. Remove what you don't need; add what you do need. If you want to completely eliminate a tab, you can't remove the tab but you can remove all the contents on the tab and you can rename the tab. You cannot add more buttons to a tab beyond its capability, which is 8 large buttons and 20 small buttons. There is no difference between large and small buttons other than the size of the button.

There are multiple ways to add content to the customizable toolbar:

  1. From the editing workspace. You can add any expression or equation, no matter how small or how large. Select what you want to save, then click and drag it to the toolbar.
  2. From Insert Symbol. When you open the Insert Symbol dialog (from MathType's Edit menu), if you drag it out of the way so you can see both the dialog and the main MathType window, you can add symbols to the toolbar. To do so, hold down Alt (Windows) or (Mac), then click and drag the symbol from Insert Symbol to an empty spot on the toolbar.
  3. From the Symbol and Template palettes. When you have a symbol or a template you use often, you can add it to the customizable toolbar. Like from Insert Symbol, hold down Alt (Windows) or (Mac), then click and drag the symbol or template from its palette to an empty spot on the toolbar. (This won't result in moving the symbol or template; it will add a copy of it to the customizable toolbar.)

Removing expressions from the toolbar

You can remove expressions from the customizable toolbar on Windows by pressing Alt and dragging the expression to any of the dark gray areas (such as between Tab 8 and Tab 9 in the screen shot above) or completely outside the MathType window. If you drop the expression where you see the "no" symbol — cirle with diagonal line through itMathType will remove it from the toolbar. On both Mac and Windows, you can right-click (or Ctrl-click) and choose Delete. There is no undo for this, so once you remove an expression from the customizable toolbar, if you decide you want it back you'll have to re-create it.

More information on the customizable toolbar

We have more information about MathType's customizable toolbar in the MathType documentation.