Tips to use with MathType itself

Situation

As a mathematician, you often use the operator symbols "much less than" and "much greater than" in MathType, and you wish there were a shortcut key for these symbols so you wouldn't have to choose them from the palette each time.

or…

You're a geometry teacher and use the "parallel to" symbol almost daily. MathType's built-in shortcut of Ctrl+Shift+K,|¹ is a little difficult to remember, and also requires 2 keys with one hand and one with another. You wish there were a way to change this shortcut to something easier to remember and requiring only 1 or 2 keys instead of 3.

MathType not only has built-in keyboard shortcuts for most symbols, templates, and menu items, but allows you to change or delete the built-in shortcuts as well as create your own new ones. This tip shows you how.

¹Some shortcut keys in MathType require pressing and releasing one key combination, then pressing and releasing another. We use the comma to distinguish between the first keypress combination and the second. Thus, Ctrl+Shift+K,| means press and release the Ctrl, Shift, and K keys, then press and release the | key. MathType will allow 4 seconds between keypress combinations.

Solution

The main method for customizing MathType shortcuts is via the Customize Keyboard dialog. To open this dialog, choose the Customize Keyboard command from the Preferences menu.

Customize Keyboard dialog

In the second example situation above, we mentioned the "parallel to" symbol. Looking at the Customize Keyboard dialog, it may not be obvious which of the listed commands to choose and what to do next. This explanation should help:

Formatting"Commands for formatting equation elements". This covers things like nudging commands and inserting tabs and new lines.
Recently Used Symbols and Templates"Commands corresponding to symbols or templates used during this session". This is pretty self-explanatory, and will be covered in more detail later in this Tip.
Menu Commands"Commands for items appearing on the menu bar". Commands like "Save", "Define Sizes", and yes, even "Customize Keyboard" are included here.
Navigation and Selection"Commands for moving around and/or selecting items in the current equation". Most of these are obvious and intuitive, such as using the Backspace key for deleting the item to the left of the insertion point.
Keyboard Modifiers (one-shots)"Commands that affect the behavior of the following typed command only". In other words, these keyboard shortcuts affect only the next character you type, but not characters beyond that. When you use a "one-shot" shortcut, you have 4 seconds to press the next key, or it is as if you never pressed the shortcut. One of the common "one-shot" hotkeys is Ctrl+G for typing Greek letters. Ctrl+G followed by an A, for example, results in the lower-case Greek letter α.
Toolbar Commands"Commands for items appearing on the toolbar". Affects not only items physically on the MathType toolbar, but things like "focus". When a symbol or template in the palette menus has the focus, it is displayed with a raised outline around it to indicate that if you click on it or press Enter the symbol or template will be inserted into the equation.
Window Control"Commands for controlling the application's windows" -- Maximize, Minimize, etc.
All Symbols/All TemplatesThese contain the symbols and templates included on MathType's symbol and template palettes.

So, since the "parallel to" symbol is, well, a symbol, our next step is to click the + to the left of the "All Symbols" command. Notice that the items are listed alphabetically, so scroll down to the entry "Parallel to from Extra Math style (Ctrl+Shift+K,|)". Several things to note here:

  • "Extra Math style" means this symbol will come from the font you've defined for Extra Math style. By default, this font is "MT Extra". If you're unfamiliar with defining fonts for MathType's styles, refer to that section of the MathType documentation.
  • If a shortcut key already exists for an item in the list, it will be shown here. Note this is the exact text that will be displayed in MathType's status bar when you point to an item with the mouse.
  • Some of the lists in the Customize Keyboard dialog can be quite long. To go quickly to the item you want, simply type the first few characters of the name of the item. For example, in this case once we click the + next to "All Symbols", we could type par and the focus would advance to that position in the list.
  • Once a command is chosen from the list, if it's a symbol or a template, the preview window will show you what this item looks like. That's a good way to verify you've chosen the one you really wanted.

We want to use the key combination Ctrl+| (which actually requires also the Shift key) for the "parallel to" symbol, so type that into the "Enter new shortcut key(s)" text entry box. In the event there's already an assignment for the keypress you've chosen, MathType will not prevent you from changing the "Assigned to" shortcut. It will warn you though, but it's your decision. It's easy to forget to click Assign, so before you click Close, verify your new shortcut is in the "Current keys" box.

It's not necessary to remove the existing Ctrl+Shift+K,| shortcut, but there's a reason you might want to. Recall that whenever you hover the mouse pointer over an item such as a symbol, MathType displays its description and its shortcut key in the status bar. If more than one shortcut key is assigned, MathType displays only one -- in most cases, the default shortcut key. If you want MathType to display the shortcut key you just assigned, click once on the old one to select it, then click Remove. Click Close when you're finished.

Assigning a shortcut to a symbol

What if you don't know the name of a symbol or template, or can't find it in the list?

There is more than one answer to this question, but the easiest way around this problem is to first use it in an equation. To continue our example above, click on the parallel line symbol in the Miscellaneous Symbols palette. Open the Customize Keyboard dialog and click the + to the left of Recently Used Symbols and Templates, and you'll see the "parallel to" symbol listed there. As you continue to use MathType, new items will be added to the bottom of this list.

The recently used list is helpful.

Other ways to create and use keyboard shortcuts

It is possible to use the Insert Symbol dialog to assign a keyboard shortcut to a symbol. (This only works for symbols and not templates, menu commands, or anything else in MathType.) You can also assign a shortcut to the macro buttons on MathType's Small Bar, or its Large or Small Tabbed Bar. Steps for doing this may be the subject of a future tip.

Sometimes putting even the simplest math expressions into a document can be problematic. Consider this example:

112+223¯416

Here's how you go about building one:

  1. In MathType's Underbar and overbar templates palette, select the Under-bar template. (If you don't know which palette this is, notice whenever you point to something with the mouse, the MathType Status Bar—the bottom of the MathType window—identifies what it is you're pointing to.)
    Choose the underbar template.
  2. Type the first addend (or minuend, if it's a subtraction problem). In this case, 112. Make sure you press Tab after you're finished typing the mixed number, so the insertion point (cursor) is outside the fraction, like this The cursor is in the correct position if it's to the right of the mixed number., not like this The cursor is incorrect if it's in the denominator..
  3. Press Enter, then type the + symbol, followed by the second addend (or subtrahend, if it's a subtraction problem). In the example, that's +223.
  4. Make sure the MathType insertion point (i.e., flashing cursor) is outside the fraction, but still within the Under-bar template, as in this example:
    Cursor after typing 2 and 2-thirds should be outside the mixed number but still inside the underbar template.
  5. In the Format menu, select Align Right.
  6. Press Tab to move outside the Under-bar template, then press Enter.
  7. Type the sum (or difference, for a subtraction), which in this case is 416.
  8. In the Format menu, select Align Right again. Note the Align Right command is specific to each template slot or "pile" (i.e., a vertical stack of lines or slots).

That completes this stacked arithmetic item. If you need more addends, just repeat steps 2 and 3 above. If you'd like more space after the plus (or minus), you can add a space from the Spaces and ellipses palette. If you often use this type of expression, you might consider putting a blank, generic copy of it onto the MathType toolbar.

If you have a tip you'd like to pass along to us for possible inclusion in our Tips & Tricks, email us.

Situation

Have you ever wondered if there's a way to type an entire equation in MathType using only the keyboard? Actually, MathType was created both for those who prefer to build their equations by pointing and clicking on menu commands and palette icons, as well as those who prefer to keep their fingers on the keyboard and use the mouse or touchpad as little as possible. This tip describes how to create equations using only the keyboard.

In this tip, you will learn these techniques:

  • Find out which keyboard shortcut is assigned to a particular symbol, template, or menu item.
  • Create your own shortcuts or change existing ones.
  • Enter equations with TeX.

Which shortcut is which?

How do you go about discovering the various keyboard shortcuts assigned to the various components that make up your equation? The simplest way is to find the item in the appropriate palette and point to it with the mouse. While hovering the mouse pointer over it, look at the status bar and both the item description and the shortcut will be displayed there:

You can learn keyboard shortcuts by watching the status bar.

If you're using Windows, have you ever noticed those underlined characters in the names on the menu bar? Depending on your display settings, they may not be underlined, but these underlined characters also identify shortcut keys. (This feature is disabled by default in Windows 10. This article describes how to enable it.) To access a menu, press Alt then press the letter underlined in the menu title. While the menu is expanded as in the example below, you can use the arrow keys to go from one menu to the next, or to navigate up and down an individual menu. To choose one of the commands, press Enter to choose the highlighted command, or press the underlined character in the command (whether the command is highlighted or not). For the example shown below, you can use the keyboard sequence Alt, E, Alt to choose the Clear command from the Edit menu.

On the Edit menu, the Clear command deletes selected content.

Some things to note when reading shortcut key abbreviations:

  • In a shortcut like the example above -- Alt, E, Alt -- the commas are merely separators; they are not part of the shortcut.
  • Sometimes you'll see the comma in connection with a keyboard shortcut requiring more than one combination of keys. The Greek letter omega, for example, has a shortcut of Ctrl+G, followed by W. You'll see this shortcut written like this: Ctrl+G, W. The comma in this case means that you must first press and release the Ctrl+G combination, then press W before the omega will appear in your equation. When using shortcuts like this, MathType gives you 4 seconds to press the second key or combination of keys after you release the first one.
  • Although it is common to identify keyboard shortcuts by using capital letters, do not press Shift unless it is specifically stated. For example, Ctrl+Shift+E is the shortcut for switching to Text style.
  • Keys separated by the + symbol must be depressed at the same time, so in the case of Text style, you must press Ctrl and Shift while pressing and releasing E. It's not necessary to precisely time these 3 keypresses to occur simultaneously. Simply keep Ctrl and Shift depressed while pressing and releasing E, then release the other 2 keys.
  • Also notice in the screen shot above, if a menu item has a shortcut key associated with it, the shortcut will be identified on the menu itself rather than on the status bar.
  • The technique of using Alt to access menus works in any Windows application.

Creating your own shortcuts

Full instructions on this are really the subject for a separate tip, but there are two methods of creating keyboard shortcuts that we'll briefly mention here. For further instructions in these techniques, refer to the MathType documentation.

If you're wanting to create or change a keyboard shortcut for a symbol, there are two ways to accomplish this. The first method is to use the Customize Keyboard command in the Preferences menu. (See the previous tip, covering this method.) The second method is to choose the Insert Symbol command from the Edit menu:

Creating a shortcut with the Insert Symbol dialog.

If you need to create or change a shortcut key for a template or a menu command, your only choice is to use the Customize Keyboard command.

Creating equations by entering TeX into MathType

If you know TeX or LaTeX, you can simply type it directly into MathType, either for the entire equation or part of it. Press Enter to complete the equation:

Typing LaTeX into MathType.

Situation:

There are at least two reasons why you might want to move your custom MathType settings (preference files, keyboard shortcuts, custom toolbar) to a new computer:

  1. You're retiring an old computer and you want to use MathType on your new computer.
  2. You have a computer at work and one at home, and you want the same MathType settings on each.

This tip covers these topics:

Preparation:

The first thing to do before moving your custom settings is to make sure you've completely exited MathType on both computers. There's more to this than simply closing the MathType windows on both computers; you also need to exit the MathType program:

To close MathType, you must use the Quit command.

If you're in the habit of inserting MathType equations into Word by clicking the "stoplight" (arrow 1 above), that's a good technique, but it doesn't close MathType. MathType remains running in the background, which makes it operate faster the next time you need it. To exit MathType, you need to use the Quit command, shown by arrow 2 above. Notice the keyboard shortcut +Q.

One way to check to see if MathType is still running is to hold down as you press and release Tab. If you see the MathType icon (as shown below), then MathType is still running. Keep depressed as you press & release Tab until MathType is highlighted, then release . Now close MathType

Command+Tab will show all open apps, and let you switch between them.

What if my new computer is a Mac and my old one is running Windows?

If you're moving from Windows to Mac (or maybe you still use your Windows computer and want to also use MathType on your new Mac), the first thing to note is that your product key for MathType 7 for Windows will also work for MathType 7 for Mac. You don't need to make a separate purchase and you don't need special authorization from us. It's OK.

If you are moving from Windows, the way you ensure MathType is completely closed is slightly different than what's described above for Mac. On your Windows computer, just like on a Mac, there's more to it than simply closing the MathType window. You also need to exit the MathType Server. The MathType Server doesn't have anything to do with a network server; its purpose is to keep MathType open in the background so it operates faster after you first use it. Note: Another important thing to know about the MathType Server is that if it is running, any customizations to the toolbar or other MathType settings will not be saved until the Server closes.

To find and close the MathType Server, look in the "Notification Area" in the lower right of your screen, near the clock:

You must close the MathType Server in order to fully exit MathType.

Click the MathType Server icon, then click Exit.

Follow the instructions below for copying your MathType toolbar, then save it at the location on your Mac identified in the next section:

  1. On Windows, there are 2 copies of the toolbar file, toolbar.eql. There is one in the MathType installation directory in Program Files. This is not the custom one, and this is not the one you need to copy to your new computer. This is the default one that's installed when you install MathType, and is used by MathType to restore the factory toolbar if it ever needs to do that. The custom toolbar is in a hidden folder at this location:

    C:\Users\[YourUserName]\AppData\Roaming\Design Science\DSMT7
  2. If you look there and can't find it, you probably don’t have File Explorer set to show hidden files & folders. Here's how to change that:
    1. At the top of the File Explorer window, click View and tick the box next to Hidden Items:
      Your files and folders settings must be set to display hidden files.
    2. Once you do that, you should be able to see the AppData folder mentioned above, and this is where your custom toolbar will be. Copy it and move it to your new computer at the location given in the next section.

Move or copy the custom MathType toolbar

There are 2 copies of the toolbar file, toolbar.eql, on your computer. There is one in the MathType installation directory in your Applications folder. This is not the custom toolbar, and this is not the one you need to copy to your new computer. This is the default one that's installed when you install MathType, and is used by MathType to restore the factory toolbar if it ever needs to do that. Here's how to find the custom toolbar:

  1. The MathType customizable toolbar is located in your user Library folder. Please note this is a HIDDEN folder, and is NOT the Library folder you'll find at "Macintosh HD/Library".
  2. To open the hidden Library folder, open a Finder window, and in the menu bar, click the Go menu.
  3. With the Go menu expanded, hold down Alt/option, and you'll see Library appear, beneath Home.
  4. Keep holding Alt/option while you click Library.
  5. Inside Library, click Application Support. Save your toolbar file there.

Move or copy MathType keyboard shortcuts and other settings

Note this is possible, but is an involved process, and fairly touchy, so we don't provide instructions here. If this is critical to you, please email us and we'll try to help.

Move or copy MathType preference files and other translators

One of MathType's powerful features is the ability to save and load "preference files", which save your font information and spacing settings. If you have custom preference files and/or custom MathType output translators, copy these 2 folders over to the new computer as well:

Applications/MathType/Preferences Applications/MathType/Translators

After you finish copying these files to your new computer, all your MathType settings should be restored. Reboot if you want, but it's not necessary.

Situation:

There are at least two reasons why you might want to move your custom MathType settings (preference files, keyboard shortcuts, custom toolbar) to a new computer:

  1. You're retiring an old computer and you want to use MathType on your new computer.
  2. You have a computer at work and one at home, and you want the same MathType settings on each.
This tip covers these topics:

Preparation:

The first thing to do before moving your custom settings is to make sure you've completely exited MathType on both computers. There's more to this than simply closing the MathType windows on both computers; you also need to exit the MathType Server. The MathType Server doesn't have anything to do with a network server; its purpose is to keep MathType open in the background so it operates faster after you first use it. Note: Another important thing to know about the MathType Server is that if it is running, any customizations to the toolbar or other MathType settings will not be saved until the Server closes.

To find and close the MathType Server, look in the "Notification Area" in the lower right of your screen, near the clock:

MathType server must be closed before moving MathType settings to a new computer.

Click the MathType Server icon, then click Exit.

What if my old computer is a Mac and my new one is Windows?

If you're moving from Mac to Windows (or maybe you still use your Mac and want to also use MathType on your new Windows computer), the first thing to note is that your product key for MathType 7 for Mac will also work for MathType 7 for Windows. You don't need to make a separate purchase and you don't need special authorization from us. It's OK.

If you are moving from a Mac, there is nothing on the Mac that corresponds to the MathType Server on Windows. Follow the instructions above to close the MathType Server on Windows, but on the Mac, when you close the MathType program, there is no other step to perform. Note though, it's still possible to close the MathType window (by clicking the red "stoplight" in the upper left corner of the window), but the program continues to run. To close the MathType program, you must use the Quit command on the MathType menu (shortcut key +Q).

Follow the instructions below for copying your MathType toolbar, then save it at the location on Windows identified in the next section:

  1. On the Mac, the MathType customizable toolbar is located in your user Library folder. Please note this is a HIDDEN folder, and is NOT the Library folder that you'll find at "Macintosh HD/Library".
  2. To open the hidden Library folder, open a Finder window, and in the menu bar, click the Go menu.
  3. With the Go menu expanded, hold down Alt/option, and you'll see Library appear, beneath Home.
  4. Keep holding Alt/option while you click Library.
  5. Inside Library, click Application Support. The toolbar file there is the one you want to copy over to Windows at the location shown in the next section.
The process described above is only for the customizable toolbar. There's not a way to transfer keyboard shortcuts from Mac to Windows.

Move or copy the custom MathType toolbar

The main file to transfer is your customized toolbar. There are 2 copies of the toolbar file, toolbar.eql, on your computer. There is one in the MathType installation directory in Program Files. This is not the custom toolbar, and this is not the one you need to copy to your new computer. This is the default one that's installed when you install MathType, and is used by MathType to restore the factory toolbar if it ever needs to do that. The custom toolbar is in a hidden folder at this location:

C:\Users\[YourUserName]\AppData\Roaming\Design Science\DSMT7

  1. If you look there and can't find it, you probably don’t have File Explorer set to show hidden files & folders. Here's how to change that:
    1. At the top of the File Explorer window, click View and tick the box next to Hidden Items:
      Your files and folders settings must be set to display hidden files.
    2. Once you do that, you should be able to see the AppData folder mentioned above, and this is where your custom toolbar will be. Copy it and move it to your new computer at the location given in the next section.

Move or copy MathType keyboard shortcuts and other settings

MathType's custom shortcuts, windows settings, and other preferences are saved in a registry setting. Open the Registry Editor by holding down the Windows key (the key that looks like a Windows logo), press and release the R key, then release the Windows key. (This shortcut may vary on non-English keyboards.) Once the Run dialog is open, type regedit and press Enter. Navigate to the path shown here:

MathType's registry settings: Computer\HKEY_CURRENT_USER\Software\Design Science\DSMT7

When you find this registry key, right-click and choose Export. Give it a file name and note where you save it (Desktop is a good place). Use a thumb drive or other method to move this registry key file to your new computer. Double-click it and answer the prompt that you do want to continue, and you'll fairly immediately receive a confirmation that the registry keys were successfully imported.

The process described above is only for Windows-to-Windows transfers. There's not a way to transfer keyboard shortcuts from Mac to Windows.

Move or copy MathType preference files and other translators

One of MathType's powerful features is the ability to save and load "preference files", which save your font information and spacing settings. If you have custom preference files and/or custom MathType output translators, copy these 2 folders and install them onto the new computer as well (note that for 32-bit Windows, there will be no (x86) as shown below):

C:\Program Files (x86)\MathType\Preferences
C:\Program Files (x86)\MathType\Translators

After you finish copying these files to your new computer, all your MathType settings should be restored. Reboot if you want, but it's not necessary.