MathType with Pages, Keynote, Numbers

MathType Desktop works well with all 3 of these applications. Instructions for Keynote and Numbers are the same as for Pages except as noted in their respective sections below.

macOS 10.14 Mojave: If you are using macOS 10.14 Mojave or later, there are specific steps to follow prior to using MathType with any of these Apple applications. Failure to do so will leave MathType unusable with these applications until the situation is corrected. Please see the instructions below.

Add an equation to Pages

To use MathType with Pages, first open Pages Preferences and place a checkmark in the box labeled Equations: Insert and edit equations with MathType. Exit Preferences. Later, if you want to use the LaTeX/MathML editor, you can uncheck this box.

With the menu command

  1. In Pages' Insert menu, click Equation.
    1. macOS Mojave: The first time you use Pages on Mojave, you'll see this dialog:
      Click OK to authorize Pages to launch MathType.
      When you see this dialog, you must click OK to authorize Pages to launch MathType. If you don't, you won't be able to use MathType with Pages.

    2. MathType will open. Create the equation in MathType, and click the red button in the upper left to close the MathType window. The first time you do this on Mojave, you'll get a dialog similar to the previous one. This one asks for authority for MathType to control Pages:
      Click OK to authorize MathType to insert the equation into Pages.
      You will see both of these dialogs only once. Click OK. This will enter the equation into the document.
      Default equation preferences: See below for instructions to set the default equation preferences for Pages. Pages will not observe MathType's "Use for new equations" settings, so you must follow these steps to set fonts and styles that will persist beyond the current equation.
  2. Using the LaTeX/MathML equation editor. If you prefer this editor, MathType can work with it if you want. To set up MathType for this, go to Cut and Copy Preferences (in the Preferences flyout of the MathType menu). From the MathML or TeX list in the middle, choose LaTeX 2.09 or later if you want to use LaTeX, and MathML 2.0 (no namespace) if you want to use MathML. Create the equation, then copy and paste it into the Equation window in Pages.
    Note: If you insert MathType equations into the document, you cannot use the LaTeX/MathML editor to edit them. If you insert LaTeX/MathML equations into the document and you double-click them, the LaTeX/MathML Equation window will open for you to edit the equation. MathType will not open by double-clicking one of these equations, but you may edit them by copying the LaTeX/MathML content to paste into MathType.

With copy & paste

We do not recommend it, but you can also create an equation in a MathType window, cut or copy it, then paste it into Pages. Two reasons we don't recommend it. One, it will result in equations that are "floating" (not part of the paragraph) or not aligned with the text of your paragraph. This is true even if the Inline property is set in MathType's Format menu. Two, you may be unable to edit them in MathType later. Results vary, depending on your version of Pages and the version of macOS that's installed on your computer, but you'll always have best results by using the command on Pages' Insert menu to open MathType.

Equations in tables

  • You may insert an equation into a table cell by double-clicking the cell so the insertion point (i.e., cursor) is flashing. Open MathType from the Dock, Finder, etc., but not from Pages' Insert menu. Create your equation then copy it and paste it into the cell.
  • You cannot double-click to edit an equation inserted into a cell this way. You must create a new one and paste it over the top of the old one.

Equations in text boxes

You cannot add equations to a text box in Pages. This is a limitation of Pages, not of MathType. It's possible to change the text wrapping properties of the equation and move it into place near the text, but it will always be floating over the text box.

Adjusting equations pasted into Pages from Keynote on iOS

If you paste an equation from Keynote for iOS into Pages for iOS, you'll need to change the Object Placement properties of the equation once you open it in Pages for macOS.

  1. Select the equation by clicking it once.
  2. In the Format pane, click the Arrange tab and click Move with Text. In the Text Wrap dropdown list, choose Inline with Text:
    Setting equation to be inline with text.
  3. Double-click the equation. In MathType's Style menu, click Define, and change the Full size to whatever font size you're using in Pages. Close the MathType window to save your changes. Now you can move the equation to wherever you need it in the document.

Edit equations in Pages

When you need to edit an equation in a document, just double-click it and it will open in the MathType window. Make changes to it, then close the window to update the equation in the document.

Note: If you insert MathType equations into the document, you cannot use the LaTeX/MathML editor to edit them. If you insert LaTeX/MathML equations into the document and you double-click them, the LaTeX/MathML Equation window will open for you to edit the equation. MathType will not open by double-clicking one of these equations, but you may edit them by copying the LaTeX/MathML content to paste into MathType.

Importing and exporting Microsoft Word documents

  • Importing work containing MathType or Equation Editor¹ equations (doc or docx) works but you will not be able to edit the equations. Also, equation numbers created using MathType's equation numbering feature in Word will not import into Pages properly and will have to be recreated.

    ¹Equation Editor in this context refers to the "original" Equation Editor included in Microsoft Office. This is sometimes called "Microsoft Equation Editor" or "Equation Editor 3". In this context, we specifically do not mean the "new" equation editor that was introduced in Word for Windows 2007, and on the Mac in Word 2011.

  • If you export a Pages document containing equations, the equations will be visible in the exported document, but will be low-quality and have a blurry appearance. They cannot be edited, either from Word or if you later re-open the Word document in Pages.

Inserting equations in Keynote is the same as for Pages and the process is not duplicated here. Only differences are shown, so see above for details.

Differences from Pages:

  1. Copy & paste. We cautioned above against using copy & paste for inserting equations into Pages. It's OK to copy & paste into Keynote. Drag & drop works also.
  2. Inline equations. Keynote does not allow inline objects, including pictures, equations, charts, or any other kind of objects. Thus, you must insert equations onto the slide and move them into position wherever you want them. One technique to simulate an inline equation is to type the entire bullet -- bullet symbol, text, and equation(s) -- into MathType, then insert into Keynote. We recommend doing this one bullet at a time and aligning the bullets, rather than trying to add more than one bullet into a single MathType object. If you're using the large black dot as a bullet symbol, the one you'll find on the Operator symbols palette -- Operator symbols palette -- is appropriate. This is how it might look:
    Keynote slide with bullets typed in [MT].
  3. Importing from or exporting to PowerPoint.
    1. Importing work from PowerPoint (ppt or pptx) works but you will not be able to edit the equations. They will be pictures that you cannot open in MathType.
    2. Exporting a Keynote presentation to PowerPoint works, but if the presentation contains equations, the equations will be removed. There will be empty placeholders where the equations used to be, but they will be useless.

Inserting equations in Numbers is the same as for Pages and the process is not duplicated here. Only differences are shown, so see above for details.

  1. MathType does not support Numbers' formula language. Equations you insert are good for labeling a heading for a table, annotating a chart, or similar purposes. You cannot compute with MathType equations.
  2. Copy & paste. We cautioned above against using copy & paste for inserting equations into Pages. It's OK to use copy & paste or drag & drop to get equations into Numbers, but please observe these cautions:
    If you use copy & paste or drag & drop, note that

    If a cell is selected when you paste, the equation will become the cell's background. It will not be possible to move or edit the equation. The only way to remove the equation is to right-click (or ctrl+click) and Clear All.
    If a cell is not selected when you paste, the equation will be "floating", and you can move it wherever you want. You can edit it by double-clicking.
    If you drag an equation from MathType and drop it into Numbers, the cell beneath the dragged equation will become selected. When you drop the equation, it will become the cell's background. It will not be possible to move or edit the equation. The only way to remove the equation is to right-click (or ctrl+click) and Clear All.
  3. Create a MathType matrix from a selection of cells in a sheet. Select a single cell or a group of cells in a Numbers sheet, then copy it and paste it into MathType. It will take a few seconds for the transformation, but when it's complete, your data will be properly formatted as a MathType matrix. Note: If there are formulas included in the selection of cells you're copying from, they will paste as values in MathType.
  4. You cannot paste a matrix from MathType as a set of values in Numbers. MathType doesn't support this.
  5. Import Microsoft Excel spreadsheets.
    • Importing work containing MathType or Equation Editor equations (xls or xlsx) works but you will not be able to edit the equations. They will be pictures you cannot open in MathType.
    • Exporting a Numbers spreadsheet containing equations also works, but its equations will be converted to graphic images that cannot be edited with MathType in Microsoft Office.

Pages, Keynote, and Numbers all use an empty placeholder equation that is added to the document, slide, or sheet when you insert a MathType equation. These default placeholder equations are actually saved equations that fix the properties for font, size and style. Since adding a new MathType equation actually causes MathType to load the saved placeholder equation, MathType's "use for new equations" command doesn't have any effect.

Note 1: If you've upgraded from iWork to the versions of Pages, Keynote, and Numbers first released in October 2013, the old iWork apps should still be in your Applications folder, in an iWork subfolder. These steps will work for both old and new versions of the apps.

Note 2: The process described below applies to all 3 Apple apps. If you're using Keynote or Numbers, replace the name of that application where you see Pages below.

We recommend saving default equations that contain the font, font size, and font attribute settings that are appropriate for your work. You can save multiple files if you wish, but note that each file, when used, must have the correct file name and must be placed inside the application's package contents as detailed below.

  1. If Pages is running, close it before proceeding.
  2. In a Finder window, go to your Applications folder and find the application icon for Pages. Control-click Pages' application icon and from the contextual menu choose "Show package contents."
    Contextual menu for Pages
  3. From there navigate to Contents/Resources/
  4. If you're using:
    1. the iWork '09 version of Pages, locate the file named default_equation.pict
    2. Pages 5.0 or newer, locate the file named MathTypeEquation.pdf.
  5. Delete this file. Note: You may need an administrator password to do this.
  6. Launch MathType from the Finder (or Launchpad, or Dock).
  7. From MathType's Style Menu, choose Define.
  8. In the resulting dialog, choose your preferred font from the Primary Font drop-down menu.
  9. Be sure to include a check next to "Italic Variables" and "Italic lower-case Greek" if you normally format your equations that way. (It's the MathType default, and the standard for mathematics typesetting.)
  10. Click OK.
  11. From the Size Menu choose, Define.
  12. Set the font size for Full to your preferred font size (it will normally be the same size as your document's text).
  13. Click OK.
  14. From the File menu choose Save-as.
  15. If you're using:
    1. the iWork '09 version of Pages, save the file using the Pict format and name it default_equation.pict.
    2. Pages 5.0 or newer, save the file using the PDF format and name it MathTypeEquation.pdf.
      Note: macOS won't let you save directly into Contents/Resources (from step 3). First save the file to another folder -- Desktop, Documents, Downloads,… -- then in a Finder window, drag it over to Contents/Resources. It may be easier to use 2 Finder windows for this, one with the location where you saved the file, and the other window displaying Contents/Resources.
  16. Changes will take effect when you restart Pages. No need to reboot.
    If you wish, you can create multiple equations each containing different settings. To use any of those you must be sure it's named as described in step 15 above, and placed in the resources under the Pages Package Contents.

After creating and saving the equation files as detailed above, open Pages and from the Insert Menu choose Equation. This will open MathType with an empty workspace and the font, font size, and font attributes will be those you created and saved to the empty equation file. You may now proceed with creating your math expressions as you would normally.