Using MathType with Adobe InDesign

InDesign is a desktop publishing application produced by Adobe. Using the techniques described here, you can insert MathType equations into InDesign as EPS images.

NOTE: If you do a lot of work in InDesign for Windows, and your work involves equations, you should consider purchasing MT-Script, a script that installs into InDesign and really makes your life easier. It performs everything described below, and more, but is not available for the Mac. We also describe another script below (step 8 in the section on Inline Equations) that you can add to InDesign yourself, and works on both Mac and Windows.

Types of Equations

In this document, we use two terms that are common in mathematics publishing. The two terms are inline equation and display equation (or displayed equation). There is a simple difference between the two. If the equation is part of the text of the paragraph and is intended to flow with the paragraph, it is called an inline equation. If the equation is set apart from the rest of the text in a paragraph of its own, it is called a display equation.

For example, we could be discussing limits and could write:

We start by finding a series expansion of left parenthesis 1 plus h right parenthesis to the power of 1 divided by h end exponent. Taking the natural logarithm of left parenthesis 1 plus h right parenthesis to the power of 1 divided by h end exponent, we have
""log left parenthesis 1 plus h right parenthesis to the power of 1 divided by h end exponent equals 1 over h log left parenthesis 1 plus h right parenthesis equals 1 minus h over 2 plus h squared over 3 minus horizontal ellipsis
provided negative 1 less than h less or equal than 1.

In this example, the equation on its own line is a display equation (even though it's not centered) and the other 3 expressions are inline expressions.

Tradeoffs: Deciding between Place and Copy & Paste

In this article we will be saving each MathType equation/expression as an EPS file and using InDesign's Place command to incorporate the equation into our document, but as we mentioned above you can also use copy & paste. So why would you choose one method over the other? To help you decide which is better for you, here are some advantages and disadvantages to the copy & paste method:

  • Advantages of copy & paste:
    • It's easy and quick. This is the number 1 advantage and it's a big one.
    • Provides the same resolution as Placing an EPS; they both print great.
    • Transportability is enhanced, since to send the document to someone else all you need is the InDesign file. If you've Placed EPS equations, you also need to send the linked equation files as well as any fonts used to create the equations.
  • Disadvantages of copy & paste:
    • Results in a larger file. How much larger depends on the document. Factors weighing in on this are how many pasted equations are in the document, as well as the physical size and complexity of the pasted equations.
    • The pasted equation will almost always need to be resized after you paste it into the document. You can do this precisely with a Transform/Scale command or you can probably get "close enough" by Shift+dragging a corner. A Placed EPS equation, by contrast, will retain whatever size you set in MathType.
    • Difficult to edit. If you need to make changes to the equation, you'll need to create the equation again in MathType, then copy, paste, resize, and position it again.
    • If you have several instances of the exact same equation, the size and editing issues are multiplied (but it's easier if you copy & paste from one place in the document to the other, rather than copying from MathType each time). By Placing an EPS, you still have only one copy of the equation to maintain, no matter how many instances of it are in your document. To edit a Placed equation, simply edit the original EPS file in MathType, save, and re-link it. All instances of it will be updated.

As you can see, there are more disadvantages to copy & paste than advantages, but if you don't have very many equations in your document and if you don't have to edit them very often, copy & paste may be best. Remember, in the discussion below we'll be using the "Place EPS" method, but if you choose to use copy & paste, the rest of the steps will still apply. The methods described in this article may not be the only way to perform a particular task, but these are the methods we recommend in most cases.

Note: This comparison of copy & paste with the Place command pertains to copy & paste directly from MathType. Results are much better if you have Equation Editor or MathType equations already in place in a Word document, and you want to use them in InDesign. When you copy & paste from Word, click the equation to select it, and with the InDesign Text Tool place the insertion point where you want the equation, then paste it there. By doing this, the baseline of each equation is already vertically aligned with the baseline of the surrounding text, and the leading for a "normal-sized" equation should be adequate to accommodate the equation. You may have to adjust the leading for taller equations to suit your own tastes or style guide, but you shouldn't have to adjust the vertical position of the equations.

Inserting MathType Display Equations Into an InDesign Document

  1. Create the text of the document as you normally would. Begin a new paragraph at the point where the display equation will be inserted, making sure the text frame is large enough to include your equation as well. (This is a situation where there are certainly other ways to perform this procedure, but including the equation in your text frame makes it easier to position the equation in relation to the text.)

    Tip:
    • You will probably want more space above and below your display equation paragraphs than you need above and below your text paragraphs. It's a good idea to create a separate paragraph style for this. Six points above and below the display equation paragraph is normally sufficient, but adjust it according to your style guide.
    • Another advantage to using a separate paragraph style is that you can create the style so the text beneath the display equation will revert back to your normal paragraph style. Otherwise, you'll have to change the justification, indentation, tabs, etc. each time.
  2. Create the equation in MathType, then save it as an EPS.
    1. To save an equation as an EPS, go to the MathType File menu, and choose Save, Save Copy As, or Save As.
    2. Choose the folder to which you will save your equation.
    3. MathType offers two options to save your equations as EPS files -- with or without a preview. The option you choose affects only the display of the equation on your monitor; it does not affect the printing.
      • Saving as "Encapsulated PostScript/PICT" (Mac), "Encapsulated PostScript/WMF" (Win), or "Encapsulated PostScript/TIFF" (Win) displays a screen preview image of the equation that will be printed. Even if you choose one of these image previews, InDesign will still generate its own preview, and will display the equation according to the display settings you have set, therefore there is no advantage in choosing one of these file formats.
      • Saving as "Encapsulated PostScript/none" (Mac or Win) does not save a preview image with the equation. InDesign will generate its own preview, and will display the equation according to the display settings you have set.
        Tip: Saving the equation without a preview image is a better option in most cases, as this will produce a smaller file. You may need to change settings for Display Performance to High Quality Display (in the View menu or contextual menu).

At this point, you have a choice of how to proceed. If your display equation does not need an equation number associated with it, continue to step 3. If you need to number your equation so you can reference it in the text of the document, proceed to the next section.

  1. In the Paragraph Formatting Controls palette, click the Align center icon. (Note the insertion point remains at the left margin of your text box until the centered paragraph contains something -- either text or an object.)
  2. Use the Place command on the File menu to insert the equation. Choose the equation you just created, then click Open. (You may leave the Show Import Options box unchecked, as the default options will work nicely.)
  3. If you chose not to use a display equation paragraph style for the equation, be sure to reformat the line or paragraph beneath the equation.

Creating a numbered display equation

If you need an equation to be numbered so you can refer to it in the text of your document (such as in the example below), follow steps 1-2 above, then continue with step 3 below.

It is not difficult to show, following the same steps, that for N1
""1+h+h22!++hNN!1h=e+O(hN).                     (1-3)
There are two problems with this formula. The larger N is, the more work is required to evaluate the expression and the more difficult it is for the computer to distinguish between hN and 0 in the left-hand side of Equation (1-3).

  1. From the Table menu, choose Insert Table. In the Insert Table dialog, set the Table Dimensions to Body Rows: 1 and Columns: 3. Leave Header Rows and Footer Rows set to zero.
  2. Open the Table Setup dialog by choosing Table > Table Options > Table Setup. In the Table Border section, choose a Weight of 0 pt. We also recommend Table Spacing of 0p6 before and -0p6 after. Click OK.
  3. Position the mouse pointer over the border between the first and second columns. A double-arrow icon will appear. Hold down the Shift key and drag the cell border to the left until the first cell is approximately 10% of the page width. Repeat this procedure to resize the third cell so that you have cell widths of approximately 10%, 80%, and 10%, left-to-right.

Tip: If your page is standard U.S. letter-size paper, the margins are at the default settings, and the InDesign Ruler Units are set to Picas (also the default setting), a convenient stop-point when dragging the cell borders is 8p0 and 43p0 for the left and right cells, respectively. For A4 paper, convenient stop-points are 7p6 (halfway between the 6 and 9 marking on the ruler) and 42p0, respectively. The reason for holding down the Shift key when dragging the cell border is that doing so keeps the table width constant.

  1. Click to place the insertion point in the middle cell of the table, and click the Align center icon on the Paragraph Formatting Controls palette. Likewise, place the insertion point in the third cell, click the Align right icon on the Paragraph Formatting Controls palette.
  2. If desired, change the vertical justification of the third cell, either by clicking the appropriate icon in the Table palette, or by selecting Table > Cell Options and setting Vertical Justification accordingly. A vertical justification of Align bottom works nicely for most equations.

Tip: Why not create a snippet out of this table? That way for subsequent numbered display equations (or simply for display equations with no number), you can insert the snippet and the table will already be formatted. If you're unfamiliar with creating snippets in InDesign, refer to the InDesign documentation. (In order to Export as an InDesign Snippet, the table must be in its own frame.)

  1. Use the Place command on the File menu to insert the equation. Choose the equation you just created, then click Open. (You may leave the Show Import Options box unchecked, as the default options will work nicely.)
  2. Type the equation number into the third cell.

Tip: For subsequent numbered display equations, it's convenient to either Place the snippet you created above or copy the entire table and paste it into the location for your next numbered display equation. Then just replace the equation and change the number. If you created a separate "Display Equation" paragraph style (see Tip after step 1 above), this style can be used for both numbered and unnumbered display equations.

Inserting MathType Inline Equations Into an InDesign Document

Inserting inline equations into an InDesign document presents several challenges. For this reason, many opt for display equations whenever possible. There are times when a display equation just will not do, so following the suggestions below might make it easier to insert inline equations.

Note: If you have an existing Word document with MathType equations and you're reusing those equations in your InDesign document, skip this section and see the introductory remarks in Batch conversion of MathType expressions to EPS files below.

  1. Create the text of your document as you normally would.
  2. Create the equation in MathType and save as an EPS as described in step 2 above.
  3. With the insertion point at the spot where you want to place your inline equation, use the Place command on the File menu to insert the equation. Choose the equation you just created, then click Open. (You may leave the Show Import Options box unchecked, as the default options will work nicely.)

There will most likely be a need for some "baseline shift" of the equation. In other words, you will need to adjust the vertical position of the equation so the baseline of the equation aligns with the baseline of the surrounding text. How you go about doing this depends on whether the equation is about the same vertical size as a line of text, or whether it is larger.

For expressions that are similar in size to the surrounding text, such as MathType equation

  1. Choose the Selection Tool. (Do not use the Direct Selection Tool for this.)

selection tool direct selection tool
Selection tool (use this one) Direct selection tool (do not use this one)

  1. Click on the newly-placed expression.
  2. From the Object menu, click Transform > Move. (For an alternative to this manual transformation process, see step 8 below.)
  3. To move the expression the proper amount, you could use trial and error and guess how much to move it. (With the expression selected, simply move it vertically with the arrow keys on the keyboard. If you do this, you don't need to click Transform > Move.) With enough experience, this may prove to be the fastest way to align the inline expression. If you need to move the expression precisely though, there is a way to determine the exact amount of vertical shift.
    1. In MathType, open the expression you just placed into your InDesign document. MathType is probably still open with this expression in the workspace anyway.
    2. Select the entire expression, then copy it.
    3. When you copy an expression to the clipboard, MathType shows the height, width, and baseline of the expression in the MathType status bar (the bottom of the MathType window). For the expression above, it would reveal this information:

Finding baseline information in MathType

The height and width is information we don't need in this case, but "B=3" means the baseline is 3 points, so that is our vertical shift.

Note: This information is also displayed in the status bar when you first save the expression as EPS, but depending on the position of your mouse pointer, the status bar may revert to standard display after momentarily showing the height, width, and baseline information. If you happen to notice the baseline information when you save the expression, you don't need to perform the step of copying the expression to the clipboard.

    1. Back to InDesign, in the Move dialog, change the value of Vertical to equal the baseline value you got from MathType, in this case, 3 pts. In InDesign, if the default units are set to picas, this is a value of 0p3, as shown below:

Adjusting an equation's baseline in InDesign.

    1. Click OK.
  1. Alternatively -- write a script and use it to effect this transform.

For expressions that are larger than the surrounding text, such as larger than text equation

  1. Perform steps 1 through 3 from the section above.
  2. The baseline for this expression is 19 pts. (Depending on the font you're using, and its size, your baseline value may be different.) If you enter "19" in the Move dialog (i.e., "0p19"), InDesign will convert it to picas accordingly (i.e., "1p7"). (You can also use the arrow keys as described in step 8 above.)
  3. Our document now looks like this:

Baseline is good, but need to fix the leading.

We can improve this!

  1. Select the line of text immediately below the expression. The easiest way to do this is to triple-click anywhere in the line with the Type Tool:

We've selected the line of text below the expression.

  1. Now we need to change the value in the Leading section of the Character Formatting Controls. The default value is 120% of the point size of the font. In our case, the font is 12 pt, so the default leading is 14.4 pt. To that value, we need to add in a value equal to two-thirds of the expression baseline. In our case, the baseline is 19 pts, so we need to add 12.7 pts to the leading (2/3 of 19), making it 31.7 pt. Press Tab or Return to accept the value. Now our document looks like this:

With the leading fixed, the paragraph looks good.

  1. You may need to adjust the amount of leading for various expressions, but in general, adding two-thirds of the expression's baseline value works pretty well.

An easier method of moving the equation into position

The process above describes copying the equation to the clipboard, then reading the baseline shift information from MathType's status bar. In fact, this information is already coded into the data in the EPS, so it's easy to let a script retrieve this information and shift the equation the proper amount. Here's how to do that.

  1. Download the equation_baseline script. (Right-click on Windows or ctrl+click on Mac, then choose to save the link.)
  2. Place it in the appropriate folder, depending on your operating system:

    Mac OS
    Users/[username]/Library/Preferences/Adobe InDesign/[version]/[language]/Scripts/Scripts Panel

    Windows Vista and later
    Users\[username]\AppData\Roaming\Adobe\InDesign\[version]\[language]\Scripts\Scripts Panel
     
  3. To open the Scripts panel in InDesign, choose Window > Utilities > Scripts.
  4. In your document, use the Selection Tool to select an EPS that you want to adjust vertically. Double-click the equation_baseline.js script in the Scripts panel:

Where to find the script in the Scripts panel.

  1. This script is written to adjust one equation at a time. It can be modified to adjust all equations in a document, but that is beyond the scope of this article. After running the script, you may still need to adjust the paragraph leading, as described above.

Batch conversion of MathType equations to EPS files

If you have an entire Microsoft Word document that you are typesetting with InDesign, by far the fastest way to do this is to "place" the entire document into InDesign as described below. If you only need some of the equations from Word, it's best to use copy & paste. By doing this, the baseline of each equation is already vertically aligned with the baseline of the surrounding text, and the leading for "normal-sized" equations is adequate to accommodate the equations. You may have to adjust the leading for taller equations to suit your own tastes or style guide, but you shouldn't have to adjust the vertical position of the equations.

If you prefer to insert separate EPS equations with the Place command, these steps may save you some time when converting the equations:

  1. Save a copy of the source document so you don't accidentally overwrite it with changes from these steps.
  2. In Word's MathType menu, click Export Equations.
  3. In the File Format section, select the Encapsulated PostScript/None option.
  4. Check the Replace equation with filename box.
  5. Click OK.

By following this procedure, MathType will save each equation as an EPS file, and place the EPSs into the folder you specify. You may then place them into your InDesign document as described above. For more information, refer to the MathType documentation.

We've already seen how to use the Place command, but how do you edit an equation once it's created and inserted into the document? To edit an equation after inserting it with the Place command, simply edit the equation in MathType, and update the link in InDesign. Note that if you inserted the equation into the document with copy & paste, you can't revise the equation this way. To edit such an equation, just re-create the equation, then copy & paste the new equation into the document.

To change a Placed/linked equation, follow these steps:

  1. Choose File > Open from the MathType menu bar.
  2. Select the equation you need to edit, and click Open.
  3. Make the desired changes, then save the equation (File > Save).
  4. Update the link from the EPS file to the document. In InDesign, select Window > Links to open the Links palette. The links representing the file(s) you changed will have an exclamation point indicating they need updating.

Updating an equation image link in InDesign's Links panel.

  1. Click the Update Link icon to update the link. Once the update process completes, you will notice the updated equation(s) in your document. When the display refreshes, it will also reflect your Display Performance settings.

Note: The reason this process is Windows only isn't because you can't import and Place a Word document on the Mac (step 4 below). That's certainly possible, but the reason you can't do this on a Mac is because the equations aren't usable when you do so.

If you have a Word document with equations, save time by placing the document and equations directly into InDesign, retaining proper vertical alignment on the equations. If the document was created in Word for Macintosh, that's fine, but this conversion doesn't work in InDesign for Mac. If you're able to open the document on Windows and do the conversion there, it should work even though it was created on the Mac. Here's how to do it:

  1. If the equations are Equation Editor equations (i.e., "Microsoft Equation 3") or OMML equations (i.e., Word 2007, 2010, 2011, 2013, or 2016 equations), convert them to MathType equations first.
    1. If you're not sure how they were created, it won't hurt to go ahead and do steps b through f.
    2. On the MathType tab in Word, choose the Convert Equations command.
    3. On the Convert Equations dialog, in the Equation types to convert group, place a checkmark in all 4 of the checkboxes.
    4. In the Convert equations to group, choose the MathType equations (OLE objects) radio button.
    5. In the Range group, choose the Whole document radio button. Click Convert.
    6. After a few seconds, a dialog will appear telling you how many equations were found and converted. Click OK.
    7. Save the document.
  2. If the equations aren't already formatted in the same font and size that you want to use in InDesign, it's better to make that conversion in Word, so after they're imported into InDesign they'll look right and will already be aligned properly. One quick way to make this conversion for the entire document is with MathType's Format Equations command.

    Remember, if you're on a Mac, the rest of this process won't work; you'll need to save the document and finish the process on a computer running Windows.
     
  3. In InDesign, start a new document or create a text box in the existing document where you want the imported text to go. As an alternative, you can create the text box as part of the next step.
  4. From InDesign's File menu, choose the Place command. In the Place dialog, choose the Word document from step 1 above, and click Open.
  5. If the insertion point was already inside a text box as the result of step 3 above, the contents of the Word document will appear there after processing is complete. If you need to create a new text box, either click once in the document where you want InDesign to create a new text box, or click and drag to create a text box the size you want (see screen shot below). When you release the mouse button, InDesign will place the contents of the Word document inside the text box.

Creating a text box in InDesign.

Note: If your Word document is already formatted the way you want it, you can simply drag it from Windows' File Explorer into InDesign, and proceed as above.

  1. The alignment of the equations should be good already, but if you need to make slight changes either in the alignment of the equations or the paragraph leading, follow the instructions above.

This is the Word document we want to import into InDesign:
The results after using the Place command to import the Word document:

Linking the equations

It's not absolutely necessary to link the equations to the document (as opposed to embedding them), but it's very advantageous to do so (see above). When InDesign imports a Word document with the Place command, it embeds the equations. Here's how to change them to linked equations:

  1. In the Links Panel, select all the equation images. Right-click and choose Unembed Link (see screen shot).
  2. In a pop-up dialog, InDesign will ask if you "want to link to the original files". Choose No, then select a folder or create a new one into which InDesign will save the equations.
  3. If you need to edit an equation, click once to select it, right-click, and choose Edit With > MathType X.X, where X.X is your version number of MathType.

Unembedding the equation links in InDesign

We gratefully acknowledge the help of Ron Anderson (Tampa Adobe User Group]]), Rodney Sauer, and Harbs, whose inputs were critical for the accuracy of this article.