Using menus and the toolbar

File

The File menu contains two items:

  • New: Clears the current contents of the editor and starts a new equation.
  • Exit: Closes the window, inserting the equation into the editor document (same as clicking on the OK button).

Edit

See Edit menu below for details on this item.

Source

The Source menu only appears when the editor is in Source view. Source view is described later in the Source Editing section and in the Tutorials.

Insert

The Insert menu has entries for inserting different types of templates (for fractions, scripts, tables, actions, etc.) as well as inserting symbols directly, by typing in the corresponding Unicode numerical reference or MathML name. The Insert menu's submenus and entries are explained in detail in Templates and symbols.

Toolbar

The Toolbar menu allows you to choose from predefined toolbars or create and use your own toolbars. See Customizing the Toolbar for more information.

Properties

The Properties menu has options that allow you to modify different kinds of properties including Fonts (such as color), Operators (such as spacing before and after it), Layout (such as background color), Tables (such as spacing between rows), MSpace properties, Actions (such as the cues for a Toggle), Common Attributes, Borders and Strikethroughs, and Linebreak Attributes. Some of the same windows will also pop open when you double-click on the appropriate element in the MathML ancestry. All these entries and windows are described in detail in Controlling Style Properties.

Preferences

The Preferences menu contains three items:

Help

The Help menu contains two items:

  • MathFlow Editor Help: Opens a browser window with the help pages. If you have placed the documentation in the directory recommended in the installation pages, the browser should automatically display the Editor help. If not, the first time you try the help you will be prompted for the location of the documentation. After that, the browser will remember where to find it.
  • About MathFlow : (not available in Source view) Opens a window with information about MathFlow's version, license information, and licensed features, as applicable.

This menu contains the actions for exporting to and importing data from the System Clipboard, as well as undoing actions and selecting.

Edit menu

The clipboard can be used in two ways. First, the clipboard is useful for cutting and pasting within the Editor. Second, the clipboard is useful for pasting data into other applications.

Equation data targeted for other applications in general requires additional formatting. For example, some XML applications may require a namespace prefix for MathML markup.

At the same time, since selection, cut, and paste are essential for efficient authoring within the Editor, clipboard operations have been optimized to make them as convenient as possible. Regardless of any extra formatting applied to data on the clipboard, expressions can always be pasted back into the Editor. Expressions with open template blanks remain intact when pasted internally, and up to three cut and paste operations can be undone.

There are several commands in the Edit menu, each explained below.

Undo

This command will undo the last cut, paste, or text editing operation. You can undo the last three operations.

Characters

Depending on how editing preferences are set up (see Customizing editing behavior/Recognize common functions, users may want to combine several characters into one <mi> tag or separate them into individual <mi> tags. To combine characters, select them and choose "group" from the menu. To separate them, select them and choose "ungroup."

Cut

This deletes the selected formula from the Editor and places its MathML markup in the System Clipboard (so that it can be pasted into other applications).

Copy

This places a presentation MathML representation of the current selection on the System Clipboard without removing the selection from the current equation.

Paste

This command pastes an equation currently on the clipboard into the current equation at the current cursor location.

If the equation or expression on the clipboard was placed there by the MathFlow Editor, it can always be pasted back into the Editor regardless of how it is formatted. However, if an equation is placed on the clipboard by an external application, the equation must be in valid MathML format, and it MUST be enclosed by ‹math› tags. The MathFlow Editor will remove the ‹math› tags before pasting the expression into the current equation, but it will not paste clipboard data as MathML unless it begins and ends with ‹math› tags. The editor will ignore any data on the clipboard before the opening math tag, and after the ending ‹math› tag. In particular, if several MathML equations are in the clipboard data, only the first will be pasted into the Editor.

Select All

This selects the entire equation currently in the Editor.

Show System Clipboard

This option simply displays the data on the system clipboard so you can verify that you have what you were expecting. Note that this is also a handy way to directly inspect the MathML structure of the current equation.

There are three toolbars available in the MathFlow editor window.

Palettes toolbar

The palettes toolbar is used to insert equation templates and symbols.

The palettes toolbar contains three primary panels. The left side of the top row of the palettes toolbar consists of dropdown palettes displaying a variety of equation templates. Templates are highlighted as you mouse over them. To insert a template, select the template by clicking it with the mouse. Note as you mouse over a template, a description is displayed in the Editor status line at the bottom of the screen. (If you don't see the description in the status line, make sure Statusline has a checkmark next to it in the View menu.)

Insert a template by clicking it in the palette.

The right side of the top row of the palettes toolbar consists of dropdown palettes containing symbol characters; the second row consists of "extra", lesser-used symbol characters. As with the template palettes, you insert a symbol by mousing over it, and then releasing or clicking the mouse once the symbol is highlighted. The MathML symbol names and their keyboard shortcuts (if any) are displayed in the Editor status line as you mouse over them on the main toolbar.

Nested dropdown palettes

The equation templates and symbol character palettes are broadly organized by theme, such as "calculus templates" or "arrow symbols." Spend a few minutes exploring the palettes toolbar to familiarize yourself with the available templates and symbols.

Tabbed toolbar

With the Tabbed toolbar, you can select an expression and drag it onto the toolbar to add a new custom button. To insert the button content at the insertion point, either click the button or right-click and choose Insert.

Add a selected expression to an empty spot on the tabbed toolbar by dragging it up.

To save a toolbar on which you've added custom expressions, choose Toolbar > Tabbed Toolbar > Save Current Toolbar As. To delete a button, choose Delete from the contextual (right-click) menu. To change the names of the tabs, first save the toolbar, then edit the toolbar file.

You can save a tabbed toolbar and load the one matching your current project.

Mini toolbar

The mini toolbar is a useful "toolbox" containing a drop-down list for style selection and icons for various editor operations.

Mini toolbar lets you choose font styles and apply other actions such as copy, paste, and undo.

Style dropdown list

Font style within the MathFlow editor window may be easily changed by clicking on the drop-down list and selecting from one of the many style options. You may also add custom styles to the drop-down list by clicking on the "Configure Styles" icon to the right of the list. See Manage custom font styles for details.

Mini Toolbar Icons

In addition to the standard "cut," "copy," "paste" and "undo" icons, there are also buttons for shrinking and magnifying the current equation, managing custom font styles, checking for proper syntax and obtaining help.

To easily align expressions, click the ruler above the text area to display a vertical line. Drag the pointer over the ruler or text area while holding down on the mouse button to move this line across the text area.

using MathFlow's ruler

Basic equation-lines alignment can be achieved by placing the lines in a table and adjusting the column and row alignment of the mtable element. For more sophisticated equation alignment, you need to edit the MathML directly in the source-view panel, and use either a table with alignment markers or the linebreaking indentation attributes. See Chapter 3 of the MathML spec for more details on these alignment methods.